Установка

Программные требования к хостингу:

  • PHP  5.3.x, 5.4.x, 5.5.x, 5.6.x, 7.1.x, 7.2.x
  • ionCube PHP Loader последней версии (Скачать Loader с сайта разработчика)
  • PHP OpenSSL support

Чтобы проверить настройки Вашего сервера, скачайте архив system_test.zip
распакуйте, прочитайте файл Readme_RU_UTF-8.txt и следуйте инструкциям.

После проверки системных требований обязательно удалите файл проверки system_test.php

Версии модуля и назначение

После того как Вы проверили свою систему на соответствия требованиям с помощью файла system_test.php, Вам нужно выбрать правильный архив, из которого Вы будете делать установку, под Вашу версию PHP и OpenCart/ocStore:

Advanced Contact Page OC3 для OpenCart/ocStore 3.0.x.x

OpenCart/ocStore 3.0.x.x PHP 5.3.x  contact_page_oc3_php53.zip
OpenCart/ocStore 3.0.x.x PHP 5.4.x  contact_page_oc3_php54.zip
OpenCart/ocStore 3.0.x.x PHP 5.5.x  contact_page_oc3_php55.zip
OpenCart/ocStore 3.0.x.x PHP 5.6.x, 7.0.x  contact_page_oc3_php56.zip
OpenCart/ocStore 3.0.x.x PHP 7.1.x  contact_page_oc3_php71.zip
OpenCart/ocStore 3.0.x.x PHP 7.2.x  contact_page_oc3_php72.zip

Advanced Contact Page OC2 для OpenCart/ocStore 2.3.x.x

OpenCart/ocStore 2.3.x.x PHP 5.3.x  contact_page_oc23_php53.zip
OpenCart/ocStore 2.3.x.x PHP 5.4.x  contact_page_oc23_php54.zip
OpenCart/ocStore 2.3.x.x PHP 5.5.x  contact_page_oc23_php55.zip
OpenCart/ocStore 2.3.x.x PHP 5.6.x, 7.0.x  contact_page_oc23_php56.zip
OpenCart/ocStore 2.3.x.x PHP 7.1.x  contact_page_oc23_php71.zip
OpenCart/ocStore 2.3.x.x PHP 7.2.x  contact_page_oc23_php72.zip

Advanced Contact Page OC2 для OpenCart/ocStore 2.0.x.x-2.2.xx

OpenCart/ocStore 2.0.x.x-2.2.x.x PHP 5.3.x  contact_page_oc22_php53.zip
OpenCart/ocStore 2.0.x.x-2.2.x.x PHP 5.4.x  contact_page_oc22_php54.zip
OpenCart/ocStore 2.0.x.x -2.2.x.x PHP 5.5.x  contact_page_oc22_php55.zip
OpenCart/ocStore 2.0.x.x-2.2.x.x PHP 5.6.x, 7.0.x  contact_page_oc22_php56.zip
OpenCart/ocStore 2.0.x.x-2.2.x.x PHP 7.1.x  contact_page_oc22_php71.zip
OpenCart/ocStore 2.0.x.x-2.2.x.x PHP 7.2.x  contact_page_oc22_php72.zip

Установка модуля по шагам

Шаг первый

Проверьте настройки Вашего хостинга при помощи файла system_test.php , данная проверка покажет Вам версию установленного PHP и версию OpenCart.

Шаг второй

Скачайте нужную версию архива (дистрибутив) в соответствии с Вашей версией OpenCart, последние версии модуля для скачивания доступны тут.

Обязательно ставьте последнюю версию модуля по состоянию на момент установки

После того как Вы скачали к себе на компьютер дистрибутив модуля (архив zip), распакуйте архивный файл, после распаковки Вы получите четыре архивных файла, каждый из которых  соответствует своей версии PHP (версию PHP Вы определили в первом шаге) см. Версии модуля и назначение.

Шаг третий

Из четырех архивных файлов, полученных на предыдущем шаге, выберите файл который соответствует Вашей версии PHP, например если у Вас PHP7.0, то это будет архивный файл contact_page_oc*_php56.zip.

Распакуйте архивный файл, перейдите в директорию upload/ и скопируйте содержимое по FTP, в корень Вашего магазина.

Корень вашего магазина это там где лежит файл index.php, config.php и директория admin

Если директория admin/ у Вас называется по другому, то предварительно перед копированием переименуйте upload/admin/ в соответствии с названием Вашей директории admin/ (как включить бинарный режим копирования см. в конце этого документа).

После копирования файлов на хостинг, зайдите в админку OpenCart, в раздел Дополнения->Модули, в списке модулей найдите Advanced Contact Page и нажмите Установить (активировать), после этого Вы можете зайти в модуль через Изменить и ввести ключ лицензии на вкладке «О модуле».

Шаг четвертый (последний)

В директории ocmod/ находится файл или файлы для установки фронтенда:

OpenCart/ocStore 3.0.x.x catalog_contact_page.ocmod.zip
OpenCart.ocStore 2.3.x.x catalog_contact_page_oc22-23.ocmod.xml
OpenCart/ocStore 2.2.x.x catalog_contact_page_oc22-23.ocmod.xml
OpenCart/ocStore 2.1.x.x catalog_contact_page_oc21.ocmod.xml
OpenCart/ocStore 2.0.x.x catalog_contact_page_oc20.ocmod.xml


Выберите нужный файл под Вашу версию OpenCart и установите через установщик дополнений, после установки не забудьте обновить кэш дополнений.

На этом установка модуля будет завершена.

Документация